Меню

1с макет ориентация страницы ландшафт

Ориентация печатной формы для нового счёта-фактуры

Функция Печать() Экспорт

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = «ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура1137»;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДокумент.ПолеСверху = 13;

Сообщить(ТабДокумент.ОриентацияСтраницы);
Сообщить(ТабДокумент.ИмяПараметровПечати);
Возврат ТабДокумент;

Письмо Минфина России от 31.01.2012 г. № 03-07-15/11
О применении новой формы счет-фактуры

Министерство финансов Российской Федерации в связи с принятием постановления Правительства Российской Федерации от 26 декабря 2011 г. N 1137 «О формах и правилах заполнения (ведения) документов, применяемых при расчетах по налогу на добавленную стоимость» сообщает.
Вышеназванным постановлением вводятся в действие новые формы счета-фактуры и порядок его заполнения, формы и порядок ведения журнала учета полученных и выставленных счетов-фактур, книг покупок и книг продаж.
Вместе с тем, учитывая опубликование текста постановления в «Собрании законодательства Российской Федерации» в январе 2012 года, полагаем возможным применение до начала очередного налогового периода, то есть до 1 апреля 2012 года, новых форм соответствующих документов наряду с формами, которые были утверждены постановлением Правительства Российской Федерации от 2 декабря 2000 г. N 914 «Об утверждении Правил ведения журналов учета полученных и выставленных счетов-фактур, книг покупок и книг продаж при расчетах по налогу на добавленную стоимость».
С.Д.ШАТАЛОВ

Источник статьи: http://forum.infostart.ru/forum83/topic51956/

Ориентация страницы ТабДок.ОринтацияСтраницы = ОриентацияСтраницы.Ландшафт

Не получается печатную форму в ландшафтной ориентации:

Делаю так:
Инвойс = СТ_ПроцедурыОбщегоНазначения.ПолучитьИнвойс(ЭтотОбъект.Ссылка);
Если ТипЗнч(Инвойс) = Тип(«ДокументСсылка.Инвойс») Тогда
Макет = ПолучитьМакет(«СличительнаяВедомость»);
ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = «ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг_ТОРГ12»;

ДатаОстатков = Новый Граница(ЭтотОбъект.МоментВремени(),ВидГраницы.Исключая);
Запрос.УстановитьПараметр(«ДатаПоступления», ДатаОстатков);
Запрос.УстановитьПараметр(«Организация», Организация);
Запрос.УстановитьПараметр(«Подразделение», Подразделение);
Запрос.УстановитьПараметр(«Склад», СкладОрдер);
Запрос.УстановитьПараметр(«Поставка», Инвойс);
Запрос.УстановитьПараметр(«Контрагент», Инвойс.Контрагент);
Запрос.УстановитьПараметр(«Договор», Инвойс.ДоговорКонтрагента);

Шапка = Макет.ПолучитьОбласть(«Шапка»);
Шапка.Параметры.Поставщик = Контрагент;
Шапка.Параметры.Склад = СкладОрдер;
ТабДокумент.Вывести(Шапка);

ДанныеПоступления = Макет.ПолучитьОбласть(«ДанныеПоступлени»);
ДанныеПоступления.Параметры.НомерПоступления = Номер;
ДанныеПоступления.Параметры.ДатаПоступления = Дата;
ДанныеПоступления.Параметры.НомерИнвойса = Инвойс.Номер;
ДанныеПоступления.Параметры.ДатаИнвойса = Инвойс.Дата;
ТабДокумент.Вывести(ДанныеПоступления);

ШапкаЗаголовкаПодписи = Макет.ПолучитьОбласть(«ШапкаЗаголовокПодписи»);
ШапкаЗаголовкаПодписи.Параметры.ОтветственныйИнвойс = Инвойс.Ответственный;
ШапкаЗаголовкаПодписи.Параметры.ОтветственныйПоступление = Ответственный;
ТабДокумент.Вывести(ШапкаЗаголовкаПодписи);

ШапкаТаблицы = Макет.ПолучитьОбласть(«ШапкаТаблицы»);
ТабДокумент.Вывести(ШапкаТаблицы);

Если Результат.Количество() <> 0 Тогда
НомерСтрокиОтчета = 0;
ИтогКолИзлишек = 0;
ИтогоСуммаИзлишек = 0;
ИтогоКолНедостача = 0;
ИтогоСуммаНедостача = 0;

Если Инвойс.ВалютаДокумента <> Справочники.Валюты.НайтиПоНаименованию(«руб.») Тогда
КурсИвойса = Инвойс.КурсВзаиморасчетов;
КонецЕсли;

Для Каждого Строка Из Результат Цикл
НомерСтрокиОтчета = НомерСтрокиОтчета + 1;
Строки = Макет.ПолучитьОбласть(«Строки»);
Строки.Параметры.Номер = НомерСтрокиОтчета;
Строки.Параметры.Номенклатура = Строка.Номенклатура;
Строки.Параметры.Намотка = Строка.Намотка;
Строки.Параметры.ЕдиницаИзмерения = Строка.Номенклатура.БазоваяЕдиницаИзмерения;
Если Строка.ПутьКоличество > 0 Тогда
Строки.Параметры.КоличесвтоНедостача = (Строка.ПутьКоличество) ;
Если Инвойс.ВалютаДокумента <> Справочники.Валюты.НайтиПоНаименованию(«руб.») Тогда
Строки.Параметры.СуммаНедостача = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(Строка.СуммаОстаток, Инвойс.ВалютаДокумента, Справочники.Валюты.НайтиПоНаименованию(«руб.»), КурсИвойса, 1, Инвойс.КратностьВзаиморасчетов, 1);
Иначе
Строки.Параметры.СуммаНедостача = Строка.СуммаОстаток
КонецЕсли;

ИтогоКолНедостача = ИтогоКолНедостача + (Строка.ПутьКоличество);
ИтогоСуммаНедостача = ИтогоСуммаНедостача + Строки.Параметры.СуммаНедостача;
Иначе
Строки.Параметры.КоличествоИзлишек = Строка.ПутьКоличество * -1;

Если Инвойс.ВалютаДокумента <> Справочники.Валюты.НайтиПоНаименованию(«руб.») Тогда
Строки.Параметры.СуммаИзлишек = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(Строка.СуммаОстаток, Инвойс.ВалютаДокумента, Справочники.Валюты.НайтиПоНаименованию(«руб.»), КурсИвойса, 1, Инвойс.КратностьВзаиморасчетов, 1);
Иначе
Строки.Параметры.СуммаИзлишек = Строка.СуммаОстаток;
КонецЕсли;

ИтогКолИзлишек = ИтогКолИзлишек + Строка.ПутьКоличество;
ИтогоСуммаИзлишек = ИтогоСуммаИзлишек + Строки.Параметры.СуммаИзлишек;
КонецЕсли;
ТабДокумент.Вывести(Строки);
КонецЦикла;

Итого = Макет.ПолучитьОбласть(«Итого»);
Итого.Параметры.ИтогКолИзлишек = ИтогКолИзлишек * -1;
Итого.Параметры.ИтогоСуммаИзлишек = ИтогоСуммаИзлишек;
Итого.Параметры.ИтогоКолНедостача = ИтогоКолНедостача;
Итого.Параметры.ИтогоСуммаНедостача = ИтогоСуммаНедостача;
ТабДокумент.Вывести(Итого);

Подвал = Макет.ПолучитьОбласть(«Подвал»);
ТабДокумент.Вывести(Подвал);

ТабДокумент.АвтоМасштаб = Истина;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДокумент.ТолькоПросмотр = Истина;
Возврат ТабДокумент;
КонецЕсли;

Источник статьи: http://forum.mista.ru/topic.php?id=469828

Как из 1С 8 сохранить табличный документ в MS Word в альбомной (ландшафтной) ориентации страниц

Оказалось, что 1С не умеет сохранять табличный документ в формат DOCX с ландшафтной ориентацией страниц. Т.е. код ниже никак не меняет ориентацию страниц при сохранении в формат DOCX.

Был немного озадачен, т.к. поиск решения не привел ни к чему.

Пришлось выкручиваться самому )))

Решение с COM объектами мне не понравилось, т.к. может не работать на сервере (на сервере 1С не все устанавливают офисный пакет MS Office или пользуются онлайн версией 365-го)

В голову пришло простое решение.

DOCX по сути ZIP архив. В нем обычные XML файлы. Найти чего не хватает оказалось легко.

Это файл ..\word\document.xml

Просто сравнить два файла с портретной и альбомной ориентацией.

Ну и реализация напрашивается сама собой — либо прочитать документ XML как строку и СтрЗаменить, либо прочитать как XML и вставить недостающие элементы и атрибуты.

Во вложении две процедуры ОриентацияЛандшафтСтр(ПолныйПутьФайл) и ОриентацияЛандшафтXML(ПолныйПутьФайл) для тех кому лень кодить 😀

Проверено на платформе 8.3.13.1926, конфигурация УТП 1.2.48.1.

З.Ы. Работает с файлами только что созданными из 1С, не надо дважды применять этот код на один и тот же файл. Сломается ))) Лень было писать еще и проверку на наличие элементов XML в файле. Так что аккуратней!

Читайте также:  Виды газона по технологии

Скачать файлы

Специальные предложения

Обновление 30.12.20 13:00

См. также

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы «Режим сравнения форм») на примере ERP 2.5 Промо

Данная публикация является продолжением описания функционирования обработки «FormCodeGenerator » в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

21.12.2020 2923 14 huxuxuya 11

Интерактивная справка по объектам 1С (подключаемое расширение)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

29.09.2020 8838 52 sapervodichka 43

Конвейер проверки качества кода

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

04.09.2019 28635 24 Stepa86 46

Алгоритмы поиска пути в графе

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

09.07.2019 19247 12 RonX01 10

Вам нравятся запросы в 1С? Промо

Речь не только о том, что простейший запрос с «легальным» оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать «в нагрузку» к тексту запроса. Все эти «Новый Запрос», «УстановитьПараметр» и последующие пляски с обработкой результата. Пора с этим заканчивать!

03.07.2019 22792 6 m-rv 88

Работа с публикациями «Инфостарт»

Работа с рублевыми публикациями на сайте «Инфостарт»: ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

13.09.2018 23498 13 RocKeR_13 16

HTTP Сервисы: Путь к своему сервису. Часть 3

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

27.08.2018 42568 63 dsdred 17

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

09.08.2018 30320 26 informa1555 26

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ («001», «Новый товар») Промо

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

01.06.2018 32080 88 m-rv 57

Работа с данными выбора

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений — уже задать без программирования не получится.

17.07.2018 54342 20 kalyaka 16

Полезные примеры составления схемы компоновки данных #2

Еще один набор примеров как решить частные задачи в СКД

22.05.2018 33899 11 SITR-utyos 13

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

06.12.2017 28561 54 kwazi 6

Заполняем по шаблону (по умолчанию) Промо

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

08.02.2018 30090 20 mvxyz 17

Паузы при исполнении кода (Sleep для 1С)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

28.11.2017 53102 14 swimdog 44

Макет в СКД — пример всех возможных типовых вариантов

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

09.11.2017 23447 77 freelancer 4

Telegram-боты

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. 🙂 редакция от 18.07.2018 Правки последней редакции выделены жирным.

01.09.2017 35826 137 PLAstic 59

Нечеткий поиск одним запросом Промо

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

28.12.2015 29639 71 vasvl123 9

Умный дом на 1С + ардуино

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

07.08.2017 24487 21 sasha777666 64

Расширения конфигураций 1С: учимся перехватывать методы

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

30.05.2017 143180 13 signum2009 48

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

13.03.2017 33530 117 romasna 49

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

14.08.2016 50049 36 Demanoidos 60

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Возможности Google Cloud Vision в распознавании текста.

08.02.2017 32346 136 kiv1c 18

Графическая схема. Управление при помощи XDTO.

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

16.01.2017 24569 109 Alxby 23

Простой редактор плана помещения JavaScript

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

23.11.2016 22777 99 igel9780 22

Быстрое определение интервалов в запросе Промо

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

01.10.2015 54509 35 ildarovich 41

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

14.11.2016 28936 16 Anton64 22

Загрузка файлов на сервер с прогрессом и докачкой

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

04.10.2016 14529 53 mrstomak 21

Несколько шаблонов для доработки типовых конфигураций

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

03.10.2016 38338 96 json 25

HTTP-сервис: отчеты [Расширение]

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

30.08.2016 28830 143 Stepa86 15

Недокументированное использование стандартных форм Upd.

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

26.07.2016 30101 89 ZhokhovM 64

Хранение файлов в томах на диске (для УПП 1.3)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

05.06.2016 60620 11 wowik 32

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

18.05.2016 65829 194 rozer 66

Остатки на каждый день в запросе

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

26.04.2016 64686 19 arakelyan 20

Еще один способ расчета остатков на каждый день в запросе

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

24.04.2016 36431 51 ildarovich 23

Вывод печатных форм с запросом данных в форму «Печать документов» из подсистемы БСП «Печать».

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму «ПечатьДокументов». Эта форма входит в состав подсистемы «Печать» из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму «Печать документа». В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы «Печать», в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы «Дополнительные отчеты и обработки» и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

29.03.2016 98541 190 lopatin 14

Источник статьи: http://infostart.ru/public/1317004/

Про дачу © 2021
Внимание! Информация, опубликованная на сайте, носит исключительно ознакомительный характер и не является рекомендацией к применению.

Adblock
detector
Наименование Файл Версия Размер