Меню

1с ориентациястраницы ландшафт не работает

Ориентация страницы ТабДок.ОринтацияСтраницы = ОриентацияСтраницы.Ландшафт

Не получается печатную форму в ландшафтной ориентации:

Делаю так:
Инвойс = СТ_ПроцедурыОбщегоНазначения.ПолучитьИнвойс(ЭтотОбъект.Ссылка);
Если ТипЗнч(Инвойс) = Тип(«ДокументСсылка.Инвойс») Тогда
Макет = ПолучитьМакет(«СличительнаяВедомость»);
ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = «ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг_ТОРГ12»;

ДатаОстатков = Новый Граница(ЭтотОбъект.МоментВремени(),ВидГраницы.Исключая);
Запрос.УстановитьПараметр(«ДатаПоступления», ДатаОстатков);
Запрос.УстановитьПараметр(«Организация», Организация);
Запрос.УстановитьПараметр(«Подразделение», Подразделение);
Запрос.УстановитьПараметр(«Склад», СкладОрдер);
Запрос.УстановитьПараметр(«Поставка», Инвойс);
Запрос.УстановитьПараметр(«Контрагент», Инвойс.Контрагент);
Запрос.УстановитьПараметр(«Договор», Инвойс.ДоговорКонтрагента);

Шапка = Макет.ПолучитьОбласть(«Шапка»);
Шапка.Параметры.Поставщик = Контрагент;
Шапка.Параметры.Склад = СкладОрдер;
ТабДокумент.Вывести(Шапка);

ДанныеПоступления = Макет.ПолучитьОбласть(«ДанныеПоступлени»);
ДанныеПоступления.Параметры.НомерПоступления = Номер;
ДанныеПоступления.Параметры.ДатаПоступления = Дата;
ДанныеПоступления.Параметры.НомерИнвойса = Инвойс.Номер;
ДанныеПоступления.Параметры.ДатаИнвойса = Инвойс.Дата;
ТабДокумент.Вывести(ДанныеПоступления);

ШапкаЗаголовкаПодписи = Макет.ПолучитьОбласть(«ШапкаЗаголовокПодписи»);
ШапкаЗаголовкаПодписи.Параметры.ОтветственныйИнвойс = Инвойс.Ответственный;
ШапкаЗаголовкаПодписи.Параметры.ОтветственныйПоступление = Ответственный;
ТабДокумент.Вывести(ШапкаЗаголовкаПодписи);

ШапкаТаблицы = Макет.ПолучитьОбласть(«ШапкаТаблицы»);
ТабДокумент.Вывести(ШапкаТаблицы);

Если Результат.Количество() <> 0 Тогда
НомерСтрокиОтчета = 0;
ИтогКолИзлишек = 0;
ИтогоСуммаИзлишек = 0;
ИтогоКолНедостача = 0;
ИтогоСуммаНедостача = 0;

Если Инвойс.ВалютаДокумента <> Справочники.Валюты.НайтиПоНаименованию(«руб.») Тогда
КурсИвойса = Инвойс.КурсВзаиморасчетов;
КонецЕсли;

Для Каждого Строка Из Результат Цикл
НомерСтрокиОтчета = НомерСтрокиОтчета + 1;
Строки = Макет.ПолучитьОбласть(«Строки»);
Строки.Параметры.Номер = НомерСтрокиОтчета;
Строки.Параметры.Номенклатура = Строка.Номенклатура;
Строки.Параметры.Намотка = Строка.Намотка;
Строки.Параметры.ЕдиницаИзмерения = Строка.Номенклатура.БазоваяЕдиницаИзмерения;
Если Строка.ПутьКоличество > 0 Тогда
Строки.Параметры.КоличесвтоНедостача = (Строка.ПутьКоличество) ;
Если Инвойс.ВалютаДокумента <> Справочники.Валюты.НайтиПоНаименованию(«руб.») Тогда
Строки.Параметры.СуммаНедостача = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(Строка.СуммаОстаток, Инвойс.ВалютаДокумента, Справочники.Валюты.НайтиПоНаименованию(«руб.»), КурсИвойса, 1, Инвойс.КратностьВзаиморасчетов, 1);
Иначе
Строки.Параметры.СуммаНедостача = Строка.СуммаОстаток
КонецЕсли;

ИтогоКолНедостача = ИтогоКолНедостача + (Строка.ПутьКоличество);
ИтогоСуммаНедостача = ИтогоСуммаНедостача + Строки.Параметры.СуммаНедостача;
Иначе
Строки.Параметры.КоличествоИзлишек = Строка.ПутьКоличество * -1;

Если Инвойс.ВалютаДокумента <> Справочники.Валюты.НайтиПоНаименованию(«руб.») Тогда
Строки.Параметры.СуммаИзлишек = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(Строка.СуммаОстаток, Инвойс.ВалютаДокумента, Справочники.Валюты.НайтиПоНаименованию(«руб.»), КурсИвойса, 1, Инвойс.КратностьВзаиморасчетов, 1);
Иначе
Строки.Параметры.СуммаИзлишек = Строка.СуммаОстаток;
КонецЕсли;

ИтогКолИзлишек = ИтогКолИзлишек + Строка.ПутьКоличество;
ИтогоСуммаИзлишек = ИтогоСуммаИзлишек + Строки.Параметры.СуммаИзлишек;
КонецЕсли;
ТабДокумент.Вывести(Строки);
КонецЦикла;

Итого = Макет.ПолучитьОбласть(«Итого»);
Итого.Параметры.ИтогКолИзлишек = ИтогКолИзлишек * -1;
Итого.Параметры.ИтогоСуммаИзлишек = ИтогоСуммаИзлишек;
Итого.Параметры.ИтогоКолНедостача = ИтогоКолНедостача;
Итого.Параметры.ИтогоСуммаНедостача = ИтогоСуммаНедостача;
ТабДокумент.Вывести(Итого);

Подвал = Макет.ПолучитьОбласть(«Подвал»);
ТабДокумент.Вывести(Подвал);

ТабДокумент.АвтоМасштаб = Истина;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДокумент.ТолькоПросмотр = Истина;
Возврат ТабДокумент;
КонецЕсли;

Источник статьи: http://forum.mista.ru/topic.php?id=469828

Не применяется ориентация страницы

Подскажите пожалуйста вроде сделал внешнюю печатную форму поступл. товаров и услуг для УПП , но не применяется ориентация страницы ландшафт.
Что неправильно делаю?

Перем ТекущийДокумент;
Перем Ссылка;

// Функция должна возвращать табличный документ. Печать документа выполняется конфигурацией.
// Если требуется отказ от печати вообще, функция должна возвращать Неопределено
Функция Печать() Экспорт
Если не ЗначениеЗаполнено(СсылкаНаОбъект) Тогда Возврат Неопределено КонецЕсли;
Возврат ПечатьПТиУ_Электра();

// Функция формирует табличный документ унифицированной формы М-4
//
// Параметры:
// Нет.
//
// Возвращаемое значение:
// Табличный документ по форме М-4 (приходный ордер).
//
Функция ПечатьПТиУ_Электра();

Читайте также:  Ваш огород сад своими руками

Макет = ПолучитьМакет(«Макет»);
ТабДокумент = Новый ТабличныйДокумент;

// Зададим параметры печатной формы по умолчанию
ТабДокумент.ПолеСверху = 0;
ТабДокумент.ПолеСлева = 0;
ТабДокумент.ПолеСнизу = 0;
ТабДокумент.ПолеСправа = 0;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДокумент.АвтоМасштаб=Истина;

ОбластьМакета = Макет.ПолучитьОбласть(«Шапка»);
ОбластьМакета.Параметры.Заполнить(ОбластьМакета);

ОбластьМакета.Параметры.ПредставлениеОрганизации = ЭтотОбъект.СсылкаНаОбъект.Организация;
ОбластьМакета.Параметры.ОрганизацияПоОКПО = ЭтотОбъект.СсылкаНаОбъект.Организация.КодПоОКПО;
НомерДокумента = ЭтотОбъект.СсылкаНаОбъект.Номер;
НомерДокументаБезНулей =Число(НомерДокумента);
ОбластьМакета.Параметры.НомерДокумента = НомерДокументаБезНулей;
ОбластьМакета.Параметры.ПредставлениеПодразделения = ЭтотОбъект.СсылкаНаОбъект.СкладОрдер;
ТабДокумент.Вывести(ОбластьМакета);

// Выводим заголовок докмента

ЗапросЗаголовокДокумента = Новый Запрос;
ЗапросЗаголовокДокумента.Текст = «ВЫБРАТЬ
| ПоступлениеТоваровУслуг.Номер КАК Номер,
| ПоступлениеТоваровУслуг.Дата КАК ДатаСоставления,
| ПоступлениеТоваровУслуг.НомерВходящегоДокумента КАК НомерСопроводительногоДокумента,
| ПоступлениеТоваровУслуг.Организация,
| ПоступлениеТоваровУслуг.Организация КАК ЮрФизЛицо,
| ПоступлениеТоваровУслуг.Контрагент.Код КАК ПоставщикКод,
| ПоступлениеТоваровУслуг.Контрагент КАК Поставщик,
| ПоступлениеТоваровУслуг.ВалютаДокумента,
| ПоступлениеТоваровУслуг.КурсВзаиморасчетов КАК Курс,
| ПоступлениеТоваровУслуг.КратностьВзаиморасчетов КАК Кратность,
| ПоступлениеТоваровУслуг.УчитыватьНДС,
| ПоступлениеТоваровУслуг.СуммаВключаетНДС,
| ПоступлениеТоваровУслуг.СчетУчетаРасчетовСКонтрагентом КАК СубСчет,
| ПоступлениеТоваровУслуг.СкладОрдер
|ИЗ
| Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
|ГДЕ
| ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент»;

ЗапросЗаголовокДокумента.УстановитьПараметр(«ТекущийДокумент»,СсылкаНаОбъект.Ссылка);
РезультатЗапросЗаголовокДокумента = ЗапросЗаголовокДокумента.Выполнить();
Выборка = РезультатЗапросЗаголовокДокумента.Выбрать();

Пока Выборка.Следующий() Цикл
ЗаголовокДокумента.Параметры.СкладНаименование = Выборка.СкладОрдер;
ЗаголовокДокумента.Параметры.ДатаСоставления = Выборка.ДатаСоставления;
ЗаголовокДокумента.Параметры.ПоставщикНаименование =Выборка.Поставщик;
ЗаголовокДокумента.Параметры.ПоставщикКод =Выборка.Поставщик.код;
ЗаголовокДокумента.Параметры.СубСчет =Выборка.СубСчет;
ТабДокумент.Вывести(ЗаголовокДокумента);
КонецЦикла;

ЗаголовокТаблицы = Макет.ПолучитьОбласть(«ЗаголовокТаблицы»);
ТабДокумент.Вывести(ЗаголовокТаблицы);

ЗапросСтрока = Новый Запрос;
ЗапросСтрока.Текст = «ВЫБРАТЬ
| ПоступлениеТоваровУслугТовары.Номенклатура,
| ПоступлениеТоваровУслугТовары.СчетУчетаБУ,
| ПоступлениеТоваровУслугТовары.Номенклатура.Код,
| ПоступлениеТоваровУслугТовары.Количество,
| ПоступлениеТоваровУслугТовары.Цена,
| ПоступлениеТоваровУслугТовары.СуммаНДС,
| ПоступлениеТоваровУслугТовары.ЕдиницаИзмерения.Код,
| ПоступлениеТоваровУслугТовары.ЕдиницаИзмерения.Наименование,
| ПоступлениеТоваровУслугТовары.Сумма
|ИЗ
| Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
|ГДЕ
| ПоступлениеТоваровУслугТовары.Ссылка = &ТекущийДокумент»;

ЗапросСтрока.УстановитьПараметр(«ТекущийДокумент»,СсылкаНаОбъект.Ссылка);
РезультатЗапросСтрока = ЗапросСтрока.Выполнить();
ВыборкаЗапросСтрока = РезультатЗапросСтрока.Выбрать();

// Инициализация итогов в документе
ИтогоКоличествоПринято = 0;
ИтогоСуммаБезНДС = 0;
ИтогоСуммаНДС = 0;
ИтогоВсегоСНДС = 0;
Ном = 0;

Пока ВыборкаЗапросСтрока.Следующий() Цикл
Строка.Параметры.ТоварНаименование = ВыборкаЗапросСтрока.Номенклатура;
Строка.Параметры.СчетУчетаБУ = ВыборкаЗапросСтрока.СчетУчетаБУ;
Строка.Параметры.ТоварКод = ВыборкаЗапросСтрока.НоменклатураКод;
Строка.Параметры.ЕдиницаИзмеренияКод= ВыборкаЗапросСтрока.ЕдиницаИзмеренияКод;
Строка.Параметры.ЕдиницаИзмеренияНаименование = ВыборкаЗапросСтрока.ЕдиницаИзмеренияНаименование;
Строка.Параметры.КоличествоПоДокументу = ВыборкаЗапросСтрока.Количество;
Строка.Параметры.КоличествоПринято = ВыборкаЗапросСтрока.Количество;
Строка.Параметры.Цена = (ВыборкаЗапросСтрока.Сумма-ВыборкаЗапросСтрока.СуммаНДС)/ВыборкаЗапросСтрока.Количество;
Строка.Параметры.СуммаБезНДС = ВыборкаЗапросСтрока.Сумма-ВыборкаЗапросСтрока.СуммаНДС;
Строка.Параметры.СуммаНДС = ВыборкаЗапросСтрока.СуммаНДС;
Строка.Параметры.ВсегоСНДС = ВыборкаЗапросСтрока.Сумма;

ИтогоКоличествоПринято = ИтогоКоличествоПринято + ВыборкаЗапросСтрока.Количество;
ИтогоСуммаБезНДС = ИтогоСуммаБезНДС + (ВыборкаЗапросСтрока.Сумма-ВыборкаЗапросСтрока.СуммаНДС);
ИтогоСуммаНДС = ИтогоСуммаНДС + ВыборкаЗапросСтрока.СуммаНДС;
ИтогоВсегоСНДС = ИтогоВсегоСНДС + ВыборкаЗапросСтрока.Сумма;

Итого=Макет.ПолучитьОбласть(«Итого»);
Итого.Параметры. ИтогоКоличествоПринято= ИтогоКоличествоПринято;
Итого.Параметры. ИтогоСуммаБезНДС= ИтогоСуммаБезНДС;
Итого.Параметры. ИтогоСуммаНДС= ИтогоСуммаНДС;
Итого.Параметры. ИтогоВсегоСНДС= ИтогоВсегоСНДС;

ЗапросСвойствДокумента = Новый Запрос; //Запрос получает данные по свойствам документа
ЗапросСвойствДокумента.Текст=»ВЫБРАТЬ
| ЗначенияСвойствОбъектов.Объект,
| ЗначенияСвойствОбъектов.Свойство,
| ЗначенияСвойствОбъектов.Значение,
| ПоступлениеТоваровУслуг.Ссылка,
| СотрудникиОрганизаций.Наименование,
| СотрудникиОрганизаций.Должность
|ИЗ
| Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
| ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
| ПО ПоступлениеТоваровУслуг.Ссылка = ЗначенияСвойствОбъектов.Объект,
| Справочник.СотрудникиОрганизаций КАК СотрудникиОрганизаций
|ГДЕ
| ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент»;
ЗапросСвойствДокумента.УстановитьПараметр(«ТекущийДокумент»,СсылкаНаОбъект.Ссылка);
РезультатЗапросСвойствДокумента = ЗапросСвойствДокумента.Выполнить();
ВыборкаЗапросСтрока = РезультатЗапросСвойствДокумента.Выбрать();

Пока ВыборкаЗапросСтрока.Следующий() Цикл
Если ВыборкаЗапросСтрока.Свойство.Наименование = «Принял» Тогда

Пр = ВыборкаЗапросСтрока.Значение;
Подвал.Параметры.Принял = ОбщегоНазначения.ИнициалыФизЛицаФамилия(Пр);

Если ВыборкаЗапросСтрока.Наименование = ВыборкаЗапросСтрока.Значение.Наименование Тогда
Подвал.Параметры.ДолжностьП = ВыборкаЗапросСтрока.Должность.Наименование;
КонецЕсли

КонецЕсли;
Если ВыборкаЗапросСтрока.Свойство.Наименование = «Сдал» Тогда

Пр = ВыборкаЗапросСтрока.Значение;
Подвал.Параметры.Сдал = ОбщегоНазначения.ИнициалыФизЛицаФамилия(Пр);

Читайте также:  У ход за газоном весной

Если ВыборкаЗапросСтрока.Наименование = ВыборкаЗапросСтрока.Значение.Наименование Тогда
Подвал.Параметры.ДолжностьС = ВыборкаЗапросСтрока.Должность.Наименование;
КонецЕсли

//ТабДокумент.Показать();
Возврат ТабДокумент;

Источник статьи: http://forum.mista.ru/topic.php?id=650883

Печать в портретном режиме, а хочу ландшафт!

Бухгалтерия предприятия, редакция 2.0 (2.0.45.5) в терминале

Внешняя форма СФ с выбором подписантов

Везде, где только можно (и видимо, там где нельзя) наставил:
ТабДокумент.ОриентацияСтраницы ориентацияСтраницы.Ландшафт;

пробовал и
ТабДокумент.КлючПараметровПечати = «Параметры_Печати_СФ_1137»;
после чего в параметрах страницы менял на ландшафт, печатал, потом открываешь снова — опять 25 = портрет

Как сделать ландшафт?

«=» — опечатка, т.е.

ТабДокумент.ОриентацияСтраницы = ориентацияСтраницы.Ландшафт;

Куда вставить
ТабДокумент.ОриентацияСтраницы = ориентацияСтраницы.Ландшафт;
чтобы наверняка? Кэш 8.2 почистил. Базу передобавил. Не помогло. (3) перед строчкой ТабДокумент.Показать() Нет у меня во внешней печатной форме Показать(). если есть строчка
Возврат ТабДокумент;
тогда перед ней Модуль Формы:

Процедура ПриОткрытии()
ТабДокумент = Новый ТабличныйДокумент;
Если Корректировочный Тогда
ТабДокумент = ПечатьКорректировочногоСчетаФактуры1137(СсылкаНаОб ъект);
Иначе
ТабДокумент = ПечатьСчетаФактуры1137(СсылкаНаОбъект);
КонецЕсли;

ТабДокумент.ПолеСверху = 13;
ТабДокумент.ПолеСлева = 0;
ТабДокумент.ПолеСнизу = 0;
ТабДокумент.ПолеСправа = 0;

ТабДокумент.ВерхнийКолонтитул.Выводить = Истина;
ТабДокумент.ВерхнийКолонтитул.НачальнаяСтраница = 2;
ТабДокумент.ВерхнийКолонтитул.ВертикальноеПоложени е = ВертикальноеПоложение.Низ;
ЗаголовокДляПечати = ОбщегоНазначения.СформироватьЗаголовокДокумента(Сс ылкаНаОбъект, «Счет-фактура») + » г.»;
ТабДокумент.ВерхнийКолонтитул.ТекстСлева = ЗаголовокДляПечати;
ТабДокумент.ВерхнийКолонтитул.ТекстСправа = «Лист [&НомерСтраницы]»;
ЭтаФорма.Заголовок = ЗаголовокДляПечати;

Элементыформы.ПолеТабличногоДокумента.ВставитьОбла сть(ТабДокумент.Область());
ЭлементыФормы.ПолеТабличногоДокумента.ОтображатьЗа головки = Ложь;
ЭлементыФормы.ПолеТабличногоДокумента.ОтображатьСе тку = Ложь;
ЭлементыФормы.ПолеТабличногоДокумента.Защита = Истина;
ЭлементыФормы.ПолеТабличногоДокумента.ТолькоПросмо тр = Истина;

Функция ПечатьСчетаФактуры1137(Ссылка) Экспорт
ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.КлючПараметровПечати = «СчетФактура1137СчетФактура1137»;
Макет = ПолучитьМакет(«СчетФактура1137»);

ДанныеДляПечати = Неопределено;
УчетнаяПолитика = Неопределено;

СобратьДанныеДляПечати(Ссылка, ДанныеДляПечати, УчетнаяПолитика);

Если ТипЗнч(ДанныеДляПечати) = Тип(«Соответствие») Тогда
Возврат Ложь;
ИначеЕсли ДанныеДляПечати = Неопределено Тогда
Возврат Ложь;
КонецЕсли;

РеквизитыСФ = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(Ссылка ,
«Дата,ВидСчетаФактуры,Исправление,НомерИсправления ,ДоговорКонтрагента»);
Дата = РеквизитыСФ.Дата;
ВидСчетаФактуры = РеквизитыСФ.ВидСчетаФактуры;
Исправление = РеквизитыСФ.Исправление;
НомерИсправления = РеквизитыСФ.НомерИсправления;
ДоговорКонтрагента = РеквизитыСФ.ДоговорКонтрагента;

СведенияОбПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице (ДанныеДляПечати.Покупатель, СсылкаНаОбъект.Дата);
СведенияОПоставщике = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице (ДанныеДляПечати.Поставщик, СсылкаНаОбъект.Дата);

ОбластьМакета = Макет.ПолучитьОбласть(«Шапка»);
ОбластьМакета.Параметры.Заполнить(ДанныеДляПечати) ;

Если СсылкаНаОбъект.Исправление Тогда
ОбластьМакета.Параметры.НомерИсправления = «Исправление №» + Строка(СсылкаНаОбъект.НомерИсправления) + » от » + Формат(СсылкаНаОбъект.Дата, «ДФ=’дд ММММ гггг'») + » г.»;
Иначе
ОбластьМакета.Параметры.НомерИсправления = «Исправление № — от —«;
КонецЕсли;

ОбластьМакета.Параметры.ПредставлениеПоставщика = «Продавец: »
+ ФормированиеПечатныхФорм.ОписаниеОрганизации(Сведе нияОПоставщике, «НаименованиеДляПечатныхФорм,»);

ОбластьМакета.Параметры.АдресПоставщика = «Адрес: » + ФормированиеПечатныхФорм.ОписаниеОрганизации(Сведе нияОПоставщике, «ЮридическийАдрес,»);

Если НЕ (СсылкаНаОбъект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.Налоговы йАгент
И СсылкаНаОбъект.ДоговорКонтрагента.ВидАгентскогоДог овора = Перечисления.ВидыАгентскихДоговоров.Нерезидент) Тогда

КПП = ФормированиеПечатныхФорм.ОписаниеОрганизации(Сведе нияОПоставщике, «КПП,», Ложь);
Если ЗначениеЗаполнено(КПП) Тогда
КПП = «/» + КПП;
КонецЕсли;
ОбластьМакета.Параметры.ИННпоставщика = «ИНН/КПП продавца: »
+ ФормированиеПечатныхФорм.ОписаниеОрганизации(Сведе нияОПоставщике, «ИНН,», Ложь) + КПП;

Читайте также:  Как уничтожить с огорода вьюнок

Иначе
ОбластьМакета.Параметры.ИННпоставщика = «ИНН/КПП продавца: —»
КонецЕсли;

ЗаголовокДляПечати = ОбщегоНазначения.СформироватьЗаголовокДокумента(Да нныеДляПечати, «Счет-фактура»);
ОбластьМакета.Параметры.Номер = ЗаголовокДляПечати;

Если СсылкаНаОбъект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаАванс Тогда

ОбластьМакета.Параметры.ПредставлениеГрузоотправит еля = «Грузоотправитель и его адрес: —«;
ОбластьМакета.Параметры.ПредставлениеГрузополучате ля = «Грузополучатель и его адрес: —«;

СведенияОГрузоотправителе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице (
?(ДанныеДляПечати.Грузоотправитель = «он же», Неопределено, ДанныеДляПечати.Грузоотправитель), СсылкаНаОбъект.Дата);
СведенияОГрузополучателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице (
ДанныеДляПечати.Грузополучатель, СсылкаНаОбъект.Дата);

Иначе
Если ЗначениеЗаполнено(Строчка.СтранаПроисхождения) Тогда
ОбластьМакета.Параметры.ПредставлениеСтраны = СокрЛП(Строчка.СтранаПроисхождения.Наименование);
КонецЕсли;
КонецЕсли;

// Проставляем прочерки в незаполненные графы в соответствии с Постановлением
Если СсылкаНаОбъект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаАванс Тогда

ОбластьМакета.Параметры.Количество = «—«;
ОбластьМакета.Параметры.Цена = «—«;
ОбластьМакета.Параметры.Стоимость = «—«;
ОбластьМакета.Параметры.Акциз = «—«;

ОбластьМакета.Параметры.СтранаПроисхожденияКод = «—«;
ОбластьМакета.Параметры.ПредставлениеСтраны = «—«;
ОбластьМакета.Параметры.ПредставлениеГТД = «—«;

Если НЕ ЗначениеЗаполнено(ОбластьМакета.Параметры.ЕдиницаИ змерения) Тогда
ОбластьМакета.Параметры.ЕдиницаИзмерения = «—«;
ОбластьМакета.Параметры.ЕдиницаИзмеренияКод = «—«;
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ОбластьМакета.Параметры.ЕдиницаИ змеренияКод) Тогда
ОбластьМакета.Параметры.ЕдиницаИзмеренияКод = «—«;
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ОбластьМакета.Параметры.Количест во) Тогда
ОбластьМакета.Параметры.Количество = «—«;
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ОбластьМакета.Параметры.Цена) Тогда
ОбластьМакета.Параметры.Цена = «—«;
КонецЕсли;

ОбластьМакета.Параметры.СтранаПроисхожденияКод = «—«;
ОбластьМакета.Параметры.ПредставлениеСтраны = «—«;
ОбластьМакета.Параметры.ПредставлениеГТД = «—«;

// Проверим возможность вывода табличного документа
СтрокаСПодвалом = Новый Массив;
СтрокаСПодвалом.Добавить(ОбластьМакета);
Если НомерСтроки = КоличествоСтрок Тогда
// Если последняя строка, то должен поместится итог и подвал
СтрокаСПодвалом.Добавить(ОбластьМакетаИтого);
СтрокаСПодвалом.Добавить(ОбластьМакетаПодвал);
КонецЕсли;

Если НЕ ФормированиеПечатныхФорм.ПроверитьВыводТабличногоД окумента(ТабДокумент, СтрокаСПодвалом) Тогда

Если КоличествоСтрок > 0 Тогда
// Вывод разделителя и заголовка таблицы на новой странице
ТабДокумент.ВывестиГоризонтальныйРазделительСтрани ц();
ТабДокумент.Вывести(ОбластьМакетаЗаголовокТаблицы) ;
КонецЕсли;

ИтогоСтоимость = ИтогоСтоимость + Строчка.СуммаБезНДС;
ИтогоСуммаНДС = ИтогоСуммаНДС + Строчка.СуммаНДС;
ИтогоВсего = ИтогоВсего + Строчка.СуммаСНДС;

Если ВыборкаСтрокТовары.Количество() > 0 Тогда
ТабДокумент.Область(ТабДокумент.ВысотаТаблицы,,Таб Документ.ВысотаТаблицы,).ВместеСоСледующим = Истина;
КонецЕсли;

// Выводим строку «Всего к оплате»

Если СсылкаНаОбъект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаАванс Тогда
ОбластьМакетаИтого.Параметры.ИтогоСтоимость = «—«;
Иначе
ОбластьМакетаИтого.Параметры.ИтогоСтоимость = ИтогоСтоимость;
КонецЕсли;
Если СчетФактураБезНДС Тогда
ОбластьМакетаИтого.Параметры.ИтогоСуммаНДС = «без НДС»;
Иначе
ОбластьМакетаИтого.Параметры.ИтогоСуммаНДС = ИтогоСуммаНДС;
КонецЕсли;
ОбластьМакетаИтого.Параметры.ИтогоВсего = ИтогоВСего;

Если СсылкаНаОбъект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.Налоговы йАгент Тогда
ОбластьМакетаПодвал.Параметры.Свидетельство = ФормированиеПечатныхФорм.ОписаниеОрганизации(Сведе нияОбПокупателе, «Свидетельство,»);
Иначе
ОбластьМакетаПодвал.Параметры.Свидетельство = ФормированиеПечатныхФорм.ОписаниеОрганизации(Сведе нияОПоставщике, «Свидетельство,»);
КонецЕсли;

// Устанавливаем параметры печати и колонтитулы

ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДокумент.ПолеСверху = 13;
ТабДокумент.ПолеСлева = 0;
ТабДокумент.ПолеСнизу = 0;
ТабДокумент.ПолеСправа = 0;

Если ТипЗнч(СсылкаНаОбъект.ДокументОснование) <> Тип(«ДокументСсылка.ОказаниеУслуг») Тогда
ТабДокумент.ВерхнийКолонтитул.Выводить = Истина;
ТабДокумент.ВерхнийКолонтитул.НачальнаяСтраница = 2;
ТабДокумент.ВерхнийКолонтитул.ВертикальноеПоложени е = ВертикальноеПоложение.Низ;
ТабДокумент.ВерхнийКолонтитул.ТекстСлева = ЗаголовокДляПечати;
ТабДокумент.ВерхнийКолонтитул.ТекстСправа = «Лист [&НомерСтраницы]»;
КонецЕсли;

ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
Возврат ТабДокумент;

Источник статьи: http://forums.kuban.ru/f1040/pechat-_v_portretnom_rezhime_hochu_landshaft-4455203.html

Adblock
detector